/lib64/libc.so.6: version `GLIBC_2.14′ not found. Why am I getting this error?

/lib64/libc.so.6: version `GLIBC_2.14′ not found. Why am I getting this error?

I am working in node js. I have installed hummus package. It installed properly. I am using this package for modifying the pdf files. While downloading the pdf I am calling hummus. Onclick of download I am getting this error.
Error: /lib64/libc.so.6: version `GLIBC_2.14′ not found (required by /var/www/html/node_modules/hummus/binding/hummus.node)
at Object.Module._extensions..node (module.js:681:18)
at Module.load (module.js:565:32)
at tryModuleLoad (module.js:505:12)
at Function.Module._load (module.js:497:3)
at Module.require (module.js:596:17)
at require (internal/module.js:11:18)
at Object. (/var/www/html/node_modules/hummus/hummus.js:5:31)
at Module._compile (module.js:652:30)
at Object.Module._extensions..js (module.js:663:10)
at Module.load (module.js:565:32)
at tryModuleLoad (module.js:505:12)
at Function.Module._load (module.js:497:3)
at Module.require (module.js:596:17)
at require (internal/module.js:11:18)
at /var/www/html/app/routes.js:2250:18
at Layer.handle [as handle_request] (/var/www/html/node_modules/express/lib/router/layer.js:95:5)

With the help of this link I have updated glibc. But still I am getting the same error. Please help me to find out the issue.
I am using CentOs 6.9

Solutions/Answers:

Solution 1:

You need to install glibc alongside your current installation of glibc as you cannot update to glibc 2.14 directly in centos 6.x safely. Follow the steps below to install glibc 2.14:

  1. mkdir ~/glibc214
  2. cd ~/glibc214
  3. wget http://ftp.gnu.org/gnu/glibc/glibc-2.14.tar.gz
  4. tar zxvf glibc-2.14.tar.gz
  5. cd glibc-2.14
  6. mkdir build
  7. cd build
  8. ../configure --prefix=/opt/glibc-2.14
  9. make -j4
  10. sudo make install
  11. export LD_LIBRARY_PATH=/opt/glibc-2.14/lib (for current login session) OR add LD_LIBRARY_PATH=/opt/glibc-2.14/lib in the /etc/environment and perform source /etc/environment(to add env variable permanently)

Solution 2:

Ok, I can not reproduce this error. However, this could work:

  1. Download the whole hummusjs package from the author https://github.com/galkahana/HummusJS (e. g. as zip).

  2. Add a new scripts entry in its package.json: "rebuild": "node-pre-gyp rebuild".

  3. cd into the package folder at your desktop and run “npm install”.

  4. For safety delete the .binding and .build folder.

  5. Edit the binding.gyp file in the package (new section before ‘sources’):

            ],
    #added by 11AND2
    "conditions": [
    [ 'OS=="linux"',
    {
        "cflags": ["-include gcc-preinclude.h"]
    }
    ]],
    #end added by 11AND2
       'sources': [
    
  6. Then run npm run rebuild and wait 🙂

  7. Try the example which failed and report back. You can also execute npm run test to run the module test cases.

Related:  Unable to install erlang on cent os